Routine Maintenance

Resolved
Operational
Started 10 months ago Lasted 2 days

Affected

Nameservers
Regions
Ahmesen - The Hague, The Netherlands
Updates
  • Resolved
    Resolved

    Routine Maintenance has been completed.

  • Monitoring
    Monitoring

    Maintainance completed and status is under scrutinity.

  • Identified
    Identified

    We are applying a new configuration to improve node redundancy and speeds.